Answered By: Ming Guang Han
Last Updated: Aug 24, 2018     Views: 10

NUS Library's proxy bookmarklet no longer works with TLS 1.0. As a result, if you are using Internet Explorer 8, 9 or 10, you may not be able to access our E-Resources.

Here are the steps to enable TLS 1.2 manually in Internet Explorer 8, 9 or 10.

Enable TLS 1.2 manually

  1. Open the Tools menu (select the cog near the top-right of Internet Explorer 10), then choose Internet options:

    Internet options menu item in the Tools menu in Internet Explorer 10

  2. Select the Advanced tab.
  3. Scroll down to the Security section at the bottom of the Settings list.
  4. Select Use TLS 1.1 and Use TLS 1.2.
  5. For extra security, deselect Use SSL 3.0. When complete, your settings should match the following:

    • Selected: Use TLS 1.0, Use TLS 1.1 and Use TLS 1.2
    • Not selected: Use SSL 2.0 and Use SSL 3.0

      Desired SSL and TLS options in the Security section

  6. Select Apply.
  7. Select OK.

Related FAQs

    Related Library Guides